ce7bda7067e8f0ad32059a03bfa60043edd11899
[AGL/meta-agl-demo.git] / recipes-qt / packagegroups / packagegroup-agl-appfw-native-qt5.bb
1 SUMMARY = "Qt5 for native GUI framework of AGL IVI profile"
2 DESCRIPTION = "A set of Qt5 packages which required by Native App Fw Subsystem"
3
4 LICENSE = "MIT"
5
6 inherit packagegroup
7
8 PACKAGES = "\
9     packagegroup-agl-appfw-native-qt5 \
10     "
11
12 ALLOW_EMPTY_${PN} = "1"
13
14 RDEPENDS_${PN} += "\
15     qtbase \
16     qtbase-dev \
17     qtbase-plugins \
18     qtbase-staticdev \
19     qtbase-tools \
20     qtdeclarative \
21     qtdeclarative-qmlplugins \
22     qtdeclarative-tools \
23     qtwayland \
24     qtwayland-plugins \
25     qtwayland-tools \
26     qtgraphicaleffects-qmlplugins \
27     qtvirtualkeyboard \
28     "
29 RDEPENDS_${PN}_checkforkrogoth += "\
30     qtwayland-examples \
31     "