Prepare master for new framework integration
[AGL/meta-agl-demo.git] / recipes-platform / packagegroups / packagegroup-agl-telematics-demo-platform.bb
1 SUMMARY = "The software for AGL telematics profile demo platform"
2 DESCRIPTION = "A set of packages belonging to the AGL telematics demo platform"
3
4 LICENSE = "MIT"
5
6 inherit packagegroup
7
8 PACKAGES = "\
9     packagegroup-agl-telematics-demo-platform \
10     "
11
12 ALLOW_EMPTY:${PN} = "1"
13
14 RDEPENDS:${PN} += "\
15     packagegroup-agl-profile-telematics \
16     "
17
18 AGL_APPS = " \
19     "
20
21 AGL_APIS = " \
22     "
23
24 RDEPENDS:${PN}:append = " \
25     gpsd \
26     sw-gpsd-udev-conf \
27     usb-can-udev-conf \
28     simple-can-simulator \
29     ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'ofono-tests gps-utils' , '', d)} \
30     ${AGL_APPS} \
31     ${AGL_APIS} \
32 "
33 # packagegroup-agl-core-navigation? (brings in geoclue...)