SPEC-3723: restructure meta-agl-demo
[AGL/meta-agl-demo.git] / recipes-platform / packagegroups / packagegroup-agl-telematics-demo-platform.bb
1 SUMMARY = "The software for AGL telematics profile demo platform"
2 DESCRIPTION = "A set of packages belonging to the AGL telematics demo platform"
3
4 LICENSE = "MIT"
5
6 inherit packagegroup
7
8 PACKAGES = "\
9     packagegroup-agl-telematics-demo-platform \
10     "
11
12 ALLOW_EMPTY_${PN} = "1"
13
14 RDEPENDS_${PN} += "\
15     packagegroup-agl-profile-telematics \
16     "
17
18 AGL_APPS = " \
19     telematics-recorder \
20     "
21
22 AGL_APIS = " \
23     agl-service-gps \
24     "
25
26 RDEPENDS_${PN}_append = " \
27     gpsd \
28     sw-gpsd-udev-conf \
29     usb-can-udev-conf \
30     simple-can-simulator \
31     ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'ofono-tests gps-utils' , '', d)} \
32     ${AGL_APPS} \
33     ${AGL_APIS} \
34 "
35 # packagegroup-agl-core-navigation? (brings in geoclue...)