SPEC-3723: restructure meta-agl-demo
[AGL/meta-agl-demo.git] / recipes-platform / packagegroups / packagegroup-agl-profile-telematics.bb
1 SUMMARY = "The middleware for AGL telematics profile"
2 DESCRIPTION = "The set of packages required for AGL Telematics Distribution"
3 LICENSE = "MIT"
4
5 inherit packagegroup
6
7 PACKAGES = "\
8     packagegroup-agl-profile-telematics \
9     profile-telematics \
10     "
11
12 ALLOW_EMPTY_${PN} = "1"
13
14 RDEPENDS_${PN} += "\
15     packagegroup-agl-image-boot \
16     packagegroup-agl-core-security \
17     ${@bb.utils.contains('VIRTUAL-RUNTIME_net_manager','connman','connman connman-client','',d)} \
18     ${@bb.utils.contains("DISTRO_FEATURES", "3g", "libqmi", "", d)} \
19     agl-login-manager \
20     agl-service-can-low-level \
21     agl-service-network \
22     can-utils \
23 "
24
25 RDEPENDS_profile-telematics = "${PN}"