Prepare master for new framework integration
[AGL/meta-agl-demo.git] / recipes-platform / packagegroups / packagegroup-agl-profile-cluster-qtcompositor.bb
1 SUMMARY = "The middleware for AGL Qt5 based cluster qtcompositor"
2 DESCRIPTION = "The set of packages required for AGL Qt5 based Cluster Demo Qtcompositor Distribution"
3 LICENSE = "MIT"
4
5 inherit packagegroup
6
7 PACKAGES = "\
8     packagegroup-agl-profile-cluster-qtcompositor \
9     profile-cluster-qt5 \
10     "
11
12 ALLOW_EMPTY:${PN} = "1"
13
14 RDEPENDS:${PN} += "\
15     packagegroup-agl-image-boot \
16     packagegroup-agl-core-security \
17     packagegroup-agl-core-connectivity \
18 "
19
20 QT_LITE = " \
21     qtbase \
22     qtdeclarative \
23     qtwayland \
24     qtgraphicaleffects-qmlplugins \
25     qtsvg-plugins \
26     qtwebsockets \
27     qtwebsockets-qmlplugins \
28     qtcompositor-conf \
29 "
30
31 RDEPENDS:${PN}:append = " \
32     ${QT_LITE} \
33 "
34
35 RDEPENDS:profile-cluster-qt5 = "${PN}"