Do not hard-code Flutter version and runtime type
[AGL/meta-agl-demo.git] / recipes-platform / packagegroups / packagegroup-agl-profile-cluster-qtcompositor.bb
1 SUMMARY = "The middleware for AGL Qt5 based cluster qtcompositor"
2 DESCRIPTION = "The set of packages required for AGL Qt5 based Cluster Demo Qtcompositor Distribution"
3 LICENSE = "MIT"
4
5 PACKAGE_ARCH = "${MACHINE_ARCH}"
6
7 inherit packagegroup
8
9 PACKAGES = "\
10     packagegroup-agl-profile-cluster-qtcompositor \
11     profile-cluster-qt5-egl \
12     "
13
14 ALLOW_EMPTY:${PN} = "1"
15
16 RDEPENDS:${PN} += "\
17     packagegroup-agl-image-boot \
18     packagegroup-agl-core-security \
19     packagegroup-agl-core-connectivity \
20 "
21
22 QT_LITE = " \
23     qtbase \
24     qtdeclarative \
25     qtwayland \
26     qtgraphicaleffects-qmlplugins \
27     qtsvg-plugins \
28 "
29
30 RDEPENDS:${PN}:append = " \
31     ${QT_LITE} \
32 "
33
34 RDEPENDS:profile-cluster-qt5-egl = "${PN}"