8865a9f0675f3a1c22b11789abf44477b391d56c
[AGL/meta-agl-demo.git] / recipes-platform / packagegroups / packagegroup-agl-ivi-multimedia.bb
1 SUMMARY = "The middlewares for AGL IVI profile"
2 DESCRIPTION = "The set of packages required by Multimedia Subsystem"
3 LICENSE = "MIT"
4
5 inherit packagegroup
6
7 PACKAGES = "\
8     packagegroup-agl-ivi-multimedia \
9     "
10
11 ALLOW_EMPTY:${PN} = "1"
12
13 PIPEWIRE_PACKAGES = " \
14     packagegroup-pipewire \
15     ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'packagegroup-pipewire-tools alsa-utils', '', d)} \
16     wireplumber-config-agl \
17     wireplumber-policy-config-agl \
18     "
19
20 RDEPENDS:${PN} += "\
21     ${@bb.utils.contains('DISTRO_FEATURES', 'pipewire', '${PIPEWIRE_PACKAGES}', '', d)} \
22     gstreamer1.0-plugins-base-meta \
23     gstreamer1.0-plugins-good-meta \
24     mpd \
25     "