Changes to support the switch to pipewire
[AGL/meta-agl-demo.git] / recipes-platform / packagegroups / packagegroup-agl-ivi-multimedia.bb
1 SUMMARY = "The middlewares for AGL IVI profile"
2 DESCRIPTION = "The set of packages required by Multimedia Subsystem"
3 LICENSE = "MIT"
4
5 inherit packagegroup
6
7 PACKAGES = "\
8     packagegroup-agl-ivi-multimedia \
9     "
10
11 ALLOW_EMPTY_${PN} = "1"
12
13 RDEPENDS_${PN} += "\
14     gstreamer1.0-plugins-base-meta \
15     gstreamer1.0-plugins-good-meta \
16     lightmediascanner-meta \
17     "
18
19 # for now: enable here for the AGL IVI demo (image-ivi and demo-platform)
20 # tbd: change based on usage in profiles
21 PIPEWIRE = "\
22     ${@bb.utils.contains('DISTRO_FEATURES', 'pipewire', 'packagegroup-pipewire', '', d)}\
23     "
24
25 RDEPENDS_${PN} += "\
26     ${PIPEWIRE} \
27     "