c2dc13c855a6854f339b0c05fc5f4df41558c638
[AGL/meta-agl-demo.git] / recipes-platform / packagegroups / packagegroup-agl-demo.bb
1 SUMMARY = "The software for AGL IVI DEMO profile"
2 DESCRIPTION = "A set of packages belong to AGL Demo"
3
4 LICENSE = "MIT"
5
6 inherit packagegroup
7
8 PACKAGES = "\
9     packagegroup-agl-demo \
10     "
11
12 ALLOW_EMPTY_${PN} = "1"
13
14 # MOST out-of-tree kernel drivers
15 #################################
16 MOST_DRIVERS ??= " \
17     most \
18     "
19 # These boards use different kernels - needs to be checked
20 MOST_DRIVERS_dragonboard-410c ?= ""
21
22
23 # HVAC dependencies
24 ###################
25 LIN_DRIVERS ??= " sllin sllin-virtual"
26 # These boards use different kernels - needs to be checked
27 LIN_DRIVERS_dra7xx-evm ?= "sllin-virtual"
28 LIN_DRIVERS_dragonboard-410c ?= "sllin-virtual"
29
30 # UNICENS service
31 UNICENS ?= " \
32     unicens-config \
33     agl-service-unicens \
34     agl-service-unicens-controller \
35     "
36
37 # Hook for demo platform configuration
38 # ATM, only used to disable btwilink module on [MH]3ULCB + Kingfisher by default,
39 # setting DEMO_ENABLE_BTWILINK to "true" in local.conf / site.conf re-enables.
40 DEMO_ENABLE_BTWILINK ?= ""
41 DEMO_PLATFORM_CONF = ""
42 DEMO_PLATFORM_CONF_append_ulcb = "${@bb.utils.contains("DEMO_ENABLE_BTWILINK", "true", "", " btwilink-disable-conf", d)}"
43
44 SMARTDEVICELINK = "${@bb.utils.contains('DISTRO_FEATURES', 'agl-sdl', \
45     'packagegroup-agl-smartdevicelink', '', d)}"
46
47 # removed: now all enablers are in meta-agl-devel/meta-audio-soundmanager-framework
48 # old audio package
49 # AUDIO-OLD = "audiomanager"
50
51 RDEPENDS_${PN} += "\
52     udisks2 \
53     ${SMARTDEVICELINK} \
54     "
55
56 # fonts
57 TTF_FONTS = " \
58     ttf-bitstream-vera \
59     ttf-dejavu-sans \
60     ttf-dejavu-sans-mono \
61     ttf-dejavu-serif \
62     ttf-noto-emoji-color \
63     source-han-sans-cn-fonts \
64     source-han-sans-jp-fonts \
65     source-han-sans-tw-fonts \
66     "
67
68
69 RDEPENDS_${PN} += " \
70     linux-firmware-ath9k \
71     linux-firmware-ralink \
72     can-utils \
73     iproute2 \
74     python-curses \
75     dhcp-client \
76     ${UNICENS} \
77     ${MOST_DRIVERS} \
78     ${LIN_DRIVERS} \
79     ${DEMO_PLATFORM_CONF} \
80     ${TTF_FONTS} \
81     ${@bb.utils.contains('DISTRO_FEATURES', 'webruntime', 'virtual/webruntime', '', d)} \
82     "
83
84