Prepare master for new framework integration
[AGL/meta-agl-demo.git] / recipes-platform / packagegroups / packagegroup-agl-demo.bb
1 SUMMARY = "The software for AGL IVI DEMO profile"
2 DESCRIPTION = "A set of packages belong to AGL Demo"
3
4 LICENSE = "MIT"
5
6 inherit packagegroup
7
8 PACKAGES = "\
9     packagegroup-agl-demo \
10     "
11
12 ALLOW_EMPTY:${PN} = "1"
13
14 # Hook for demo platform configuration
15 # ATM, only used to disable btwilink module on [MH]3ULCB + Kingfisher by default,
16 # setting DEMO_ENABLE_BTWILINK to "true" in local.conf / site.conf re-enables.
17 DEMO_ENABLE_BTWILINK ?= ""
18 DEMO_PLATFORM_CONF = ""
19 DEMO_PLATFORM_CONF:append:ulcb = "${@bb.utils.contains("DEMO_ENABLE_BTWILINK", "true", "", " btwilink-disable-conf", d)}"
20
21 RDEPENDS:${PN} += "\
22     udisks2 \
23     "
24
25 # fonts
26 TTF_FONTS = " \
27     ttf-bitstream-vera \
28     ttf-dejavu-sans \
29     ttf-dejavu-sans-mono \
30     ttf-dejavu-serif \
31     ttf-noto-emoji-color \
32     source-han-sans-cn-fonts \
33     source-han-sans-jp-fonts \
34     source-han-sans-tw-fonts \
35     source-han-sans-kr-fonts \
36     "
37
38
39 RDEPENDS:${PN} += " \
40     linux-firmware-ath9k \
41     linux-firmware-ralink \
42     can-utils \
43     cannelloni \
44     iproute2 \
45     ${DEMO_PLATFORM_CONF} \
46     ${TTF_FONTS} \
47     ${@bb.utils.contains('DISTRO_FEATURES', 'webruntime', 'virtual/webruntime', '', d)} \
48     "