9042de0ea54a81ac8fb5b1140709bf852cb3dd62
[AGL/meta-agl-demo.git] / recipes-platform / packagegroups / packagegroup-agl-demo.bb
1 SUMMARY = "The software for AGL IVI DEMO profile"
2 DESCRIPTION = "A set of packages belong to AGL Demo"
3
4 LICENSE = "MIT"
5
6 inherit packagegroup
7
8 PACKAGES = "\
9     packagegroup-agl-demo \
10     "
11
12 ALLOW_EMPTY_${PN} = "1"
13
14
15 RDEPENDS_${PN} += "\
16     packagegroup-agl-appfw \
17     homescreen \
18     "
19
20 # fonts
21 TTF_FONTS = " \
22     ttf-bitstream-vera \
23     ttf-dejavu-sans \
24     ttf-dejavu-sans-mono \
25     ttf-dejavu-serif \
26     "
27
28 RDEPENDS_${PN} += " \
29     linux-firmware-ath9k \
30     can-utils \
31     iproute2 \
32     python-curses \
33     dhcp-client \
34     ${TTF_FONTS} \
35     "