Remove agl-sdl integration as the layer is dysfunctional
[AGL/meta-agl-demo.git] / recipes-platform / packagegroups / packagegroup-agl-demo.bb
1 SUMMARY = "The software for AGL IVI DEMO profile"
2 DESCRIPTION = "A set of packages belong to AGL Demo"
3
4 LICENSE = "MIT"
5
6 inherit packagegroup
7
8 PACKAGES = "\
9     packagegroup-agl-demo \
10     "
11
12 ALLOW_EMPTY_${PN} = "1"
13
14 # MOST out-of-tree kernel drivers
15 #################################
16 MOST_DRIVERS ??= " \
17     most \
18     "
19 # These boards use different kernels - needs to be checked
20 MOST_DRIVERS_dragonboard-410c ?= ""
21 MOST_DRIVERS_cyclone5 ?= ""
22
23
24 # HVAC dependencies
25 ###################
26 LIN_DRIVERS ??= " sllin sllin-virtual"
27 # These boards use different kernels - needs to be checked
28 LIN_DRIVERS_dra7xx-evm ?= "sllin-virtual"
29 LIN_DRIVERS_dragonboard-410c ?= "sllin-virtual"
30
31 # UNICENS service
32 UNICENS ?= " \
33     unicens-config \
34     agl-service-unicens \
35     agl-service-unicens-controller \
36     "
37
38 # Hook for demo platform configuration
39 # ATM, only used to disable btwilink module on [MH]3ULCB + Kingfisher by default,
40 # setting DEMO_ENABLE_BTWILINK to "true" in local.conf / site.conf re-enables.
41 DEMO_ENABLE_BTWILINK ?= ""
42 DEMO_PLATFORM_CONF = ""
43 DEMO_PLATFORM_CONF_append_ulcb = "${@bb.utils.contains("DEMO_ENABLE_BTWILINK", "true", "", " btwilink-disable-conf", d)}"
44
45 RDEPENDS_${PN} += "\
46     udisks2 \
47     "
48
49 # fonts
50 TTF_FONTS = " \
51     ttf-bitstream-vera \
52     ttf-dejavu-sans \
53     ttf-dejavu-sans-mono \
54     ttf-dejavu-serif \
55     ttf-noto-emoji-color \
56     source-han-sans-cn-fonts \
57     source-han-sans-jp-fonts \
58     source-han-sans-tw-fonts \
59     "
60
61
62 RDEPENDS_${PN} += " \
63     linux-firmware-ath9k \
64     linux-firmware-ralink \
65     can-utils \
66     iproute2 \
67     dhcp-client \
68     ${UNICENS} \
69     ${MOST_DRIVERS} \
70     ${LIN_DRIVERS} \
71     ${DEMO_PLATFORM_CONF} \
72     ${TTF_FONTS} \
73     ${@bb.utils.contains('DISTRO_FEATURES', 'webruntime', 'virtual/webruntime', '', d)} \
74     "