Add udisks to agl demo packagegroup
[AGL/meta-agl-demo.git] / recipes-platform / packagegroups / packagegroup-agl-demo.bb
1 SUMMARY = "The software for AGL IVI DEMO profile"
2 DESCRIPTION = "A set of packages belong to AGL Demo"
3
4 LICENSE = "MIT"
5
6 inherit packagegroup
7
8 PACKAGES = "\
9     packagegroup-agl-demo \
10     "
11
12 ALLOW_EMPTY_${PN} = "1"
13
14
15 RDEPENDS_${PN} += "\
16     packagegroup-agl-appfw \
17     homescreen \
18     udisks \
19     "
20
21 # fonts
22 TTF_FONTS = " \
23     ttf-bitstream-vera \
24     ttf-dejavu-sans \
25     ttf-dejavu-sans-mono \
26     ttf-dejavu-serif \
27     "
28
29 RDEPENDS_${PN} += " \
30     linux-firmware-ath9k \
31     can-utils \
32     iproute2 \
33     python-curses \
34     dhcp-client \
35     ${TTF_FONTS} \
36     "