02926d34ea64db387735cae50a352d6a5987a579
[AGL/meta-agl-demo.git] / recipes-platform / packagegroups / packagegroup-agl-demo.bb
1 SUMMARY = "The software for AGL IVI DEMO profile"
2 DESCRIPTION = "A set of packages belong to AGL Demo"
3
4 LICENSE = "MIT"
5
6 inherit packagegroup
7
8 PACKAGES = "\
9     packagegroup-agl-demo \
10     "
11
12 # Hook for demo platform configuration
13 # ATM, only used to disable btwilink module on [MH]3ULCB + Kingfisher by default,
14 # setting DEMO_ENABLE_BTWILINK to "true" in local.conf / site.conf re-enables.
15 DEMO_ENABLE_BTWILINK ?= ""
16 DEMO_PLATFORM_CONF = ""
17 DEMO_PLATFORM_CONF:append:ulcb = "${@bb.utils.contains("DEMO_ENABLE_BTWILINK", "true", "", " btwilink-disable-conf", d)}"
18
19 # fonts
20 TTF_FONTS = " \
21     ttf-bitstream-vera \
22     ttf-dejavu-sans \
23     ttf-dejavu-sans-mono \
24     ttf-dejavu-serif \
25     ttf-noto-emoji-color \
26     source-han-sans-cn-fonts \
27     source-han-sans-jp-fonts \
28     source-han-sans-tw-fonts \
29     source-han-sans-kr-fonts \
30     "
31
32 RDEPENDS:${PN} += " \
33     udisks2 \
34     linux-firmware-ath9k \
35     linux-firmware-ralink \
36     can-utils \
37     cannelloni \
38     iproute2 \
39     ${DEMO_PLATFORM_CONF} \
40     ${TTF_FONTS} \
41     "