Use split out AGL QtQuickControls2 repositories
[AGL/meta-agl-demo.git] / recipes-platform / packagegroups / packagegroup-agl-demo-platform.bb
1 SUMMARY = "The software for DEMO platform of AGL IVI profile"
2 DESCRIPTION = "A set of packages belong to AGL Demo Platform"
3
4 LICENSE = "MIT"
5
6 inherit packagegroup
7
8 PACKAGES = "\
9     packagegroup-agl-demo-platform \
10     "
11
12 ALLOW_EMPTY_${PN} = "1"
13
14 RDEPENDS_${PN} += "\
15     packagegroup-agl-image-ivi \
16     "
17
18 RDEPENDS_${PN} += "\
19     packagegroup-agl-demo \
20     "
21
22 MOST_DRIVERS = " "
23 MOST_DRIVERS_append = " \
24     aim-cdev \
25     aim-network \
26     aim-sound \
27     aim-v4l2 \
28     hdm-dim2 \
29     hdm-i2c \
30     hdm-usb \
31     mocca-usb \
32     mostcore \
33     "
34
35 # HVAC dependencies depend on drivers above
36 MOST_HVAC = " "
37 MOST_HVAC_append = " \
38     ${MOST_DRIVERS} \
39     unicens \
40     vod-server \
41     "
42
43 # can-lin is a binary and only for porter :(
44 MOST_HVAC_append_porter = " \
45     can-lin \
46     "
47
48 # mapviewer and mapviewer-demo requires AGL CES2017 demo mock-up
49 MAPVIEWER = " "
50 MAPVIEWER_append_porter = " \
51     mapviewer \
52     mapviewer-demo \
53     "
54
55 AGL_APPS = " \
56     controls \
57     dashboard \
58     hvac \
59     mediaplayer \
60     mixer \
61     navigation \
62     phone \
63     poiapp \
64     radio \
65     settings \
66     "
67
68 RDEPENDS_${PN}_append = " \
69     qtquickcontrols2-agl \
70     qtquickcontrols2-agl-style \
71     linux-firmware-ralink \
72     ${MAPVIEWER} \
73     ${MOST_HVAC} \
74     ${AGL_APPS} \
75     "
76
77