alexa-viewer: add recipe and conditionally add to demo image
[AGL/meta-agl-demo.git] / recipes-platform / packagegroups / packagegroup-agl-demo-platform.bb
1 SUMMARY = "The software for DEMO platform of AGL IVI profile"
2 DESCRIPTION = "A set of packages belong to AGL Demo Platform"
3
4 LICENSE = "MIT"
5
6 inherit packagegroup
7
8 PACKAGES = "\
9     packagegroup-agl-demo-platform \
10     "
11
12 ALLOW_EMPTY_${PN} = "1"
13
14 RDEPENDS_${PN} += "\
15     packagegroup-agl-image-ivi \
16     "
17
18 RDEPENDS_${PN} += "\
19     packagegroup-agl-profile-graphical-qt5 \
20     packagegroup-agl-demo \
21     "
22
23 # MOST out-of-tree kernel drivers
24 #################################
25 MOST_DRIVERS ??= " \
26     most \
27     "
28 # These boards use different kernels - needs to be checked
29 MOST_DRIVERS_dra7xx-evm ?= ""
30 MOST_DRIVERS_dragonboard-410c ?= ""
31
32
33 # HVAC dependencies
34 ###################
35 LIN_DRIVERS ??= " sllin sllin-virtual"
36 # These boards use different kernels - needs to be checked
37 LIN_DRIVERS_dra7xx-evm ?= "sllin-virtual"
38 LIN_DRIVERS_dragonboard-410c ?= "sllin-virtual"
39
40 # UNICENS service
41 UNICENS ?= " \
42     unicens-config \
43     agl-service-unicens \
44     "
45
46
47 AGL_APPS = " \
48     dashboard \
49     hvac \
50     mediaplayer \
51     virtual/navigation \
52     phone \
53     poiapp \
54     radio \
55     settings \
56     ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'taskmanager' , '', d)} \
57     ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'unzip' , '', d)} \
58     high-level-viwi-service \
59     agl-service-signal-composer \
60     low-can-demo \
61     virtual/mixer \
62     ${@bb.utils.contains('IMAGE_FEATURES', 'agl-voiceagent-alexa', 'alexa-viewer' , '', d)} \
63     "
64
65 QTAGLEXTRAS = "${@bb.utils.contains("DISTRO_FEATURES", "agl-hmi-framework", " qtaglextras", "",d)}"
66
67 # Cluster demo support.
68 # ATM no cluster map viewer is supported with the older navigation application.
69 MAPVIEWER = "${@bb.utils.contains("PREFERRED_RPROVIDER_virtual/navigation", "ondemandnavi", "tbtnavi", "",d)}"
70 CLUSTER_SUPPORT_PACKAGES = " \
71         ${MAPVIEWER} \
72         cluster-demo-network-config \
73         cluster-lin-bridging-config \
74         cluster-demo-simulator \
75 "
76 CLUSTER_SUPPORT = "${@bb.utils.contains("DISTRO_FEATURES", "agl-cluster-demo-support", "${CLUSTER_SUPPORT_PACKAGES}", "",d)}"
77
78 DEMO_UNIT_CONF = ""
79 # Hook for demo platform configuration
80 # ATM used for:
81 # 1) Adding udev configuration and scripts for supporting USB attached
82 #    I2C devices for RTC and HVAC LED support.
83 DEMO_UNIT_CONF += " demo-i2c-udev-conf "
84
85 # Preload poi API key for demo if requested, and potentially maps for older
86 # navigation application if it is configured.
87 DEMO_MAPS_LOCALE ?= "uk"
88 DEMO_PRELOAD_MAPS = "${@bb.utils.contains("PREFERRED_RPROVIDER_virtual/navigation", "navigation", " navigation-maps-${DEMO_MAPS_LOCALE}", "",d)}"
89
90 # Preload only if agl-demo-preload is set
91 DEMO_PRELOAD = "${@bb.utils.contains("DISTRO_FEATURES", "agl-demo-preload", " ${DEMO_PRELOAD_MAPS} ${DEMO_UNIT_CONF} poiapp-api-key", "",d)}"
92
93
94 # Hook for demo platform configuration
95 # ATM, only used to disable btwilink module on [MH]3ULCB + Kingfisher by default,
96 # setting DEMO_ENABLE_BTWILINK to "true" in local.conf / site.conf re-enables.
97 DEMO_ENABLE_BTWILINK ?= ""
98 DEMO_PLATFORM_CONF = ""
99 DEMO_PLATFORM_CONF_append_ulcb = "${@bb.utils.contains("DEMO_ENABLE_BTWILINK", "true", "", " btwilink-disable-conf", d)}"
100
101 RDEPENDS_${PN}_append = " \
102     qtquickcontrols2-agl \
103     qtquickcontrols2-agl-style \
104     linux-firmware-ralink \
105     ${UNICENS} \
106     ${MOST_DRIVERS} \
107     ${LIN_DRIVERS} \
108     ${AGL_APPS} \
109     ${QTAGLEXTRAS} \
110     ${CLUSTER_SUPPORT} \
111     ${DEMO_PRELOAD} \
112     ${DEMO_PLATFORM_CONF} \
113     "