Prepare master for new framework integration
[AGL/meta-agl-demo.git] / recipes-platform / packagegroups / packagegroup-agl-demo-platform.bb
1 SUMMARY = "The software for DEMO platform of AGL IVI profile"
2 DESCRIPTION = "A set of packages belong to AGL Demo Platform"
3
4 LICENSE = "MIT"
5
6 inherit packagegroup
7
8 PROVIDES = "${PACKAGES}"
9 PACKAGES = "\
10     packagegroup-agl-demo-platform \
11     packagegroup-agl-demo-platform-devel \
12     "
13
14 ALLOW_EMPTY:${PN} = "1"
15
16 RDEPENDS:${PN} += "\
17     packagegroup-agl-image-ivi \
18     "
19
20 RDEPENDS:${PN} += "\
21     packagegroup-agl-profile-graphical-qt5 \
22     packagegroup-hmi-framework \
23     packagegroup-agl-demo \
24     "
25
26
27 DEMO_UNIT_CONF ?= ""
28 # Hook for demo platform configuration
29 # ATM used for:
30 # 1) Adding udev configuration and scripts for supporting USB attached
31 #    I2C devices for RTC and HVAC LED support.
32 DEMO_UNIT_CONF += " demo-i2c-udev-conf "
33
34 # Preload only if agl-demo-preload is set
35 DEMO_PRELOAD = "${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", " ${DEMO_UNIT_CONF} poiapp-api-key", "",d)}"
36
37 RDEPENDS:${PN}:append = " \
38     weston-ini-conf \
39     qtquickcontrols2-agl \
40     qtquickcontrols2-agl-style \
41     ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'unzip' , '', d)} \
42     ${DEMO_PRELOAD} \
43     "
44
45 # NOTE: Currently no coverage versions for the application widgets,
46 #       they should be added here when available.
47 #       Also, the navigation and mixer debug widgets are currently
48 #       specified explicitly, as there's no simple way to derive their
49 #       names from the virtual/ RPROVIDES at present.
50 RDEPENDS:${PN}-devel = " \
51     packagegroup-hmi-framework-devel \
52     "