Restore cluster and telematics demo images
[AGL/meta-agl-demo.git] / recipes-platform / packagegroups / packagegroup-agl-demo-platform.bb
1 SUMMARY = "The software for DEMO platform of AGL IVI profile"
2 DESCRIPTION = "A set of packages belong to AGL Demo Platform"
3
4 LICENSE = "MIT"
5
6 inherit packagegroup
7
8 PROVIDES = "${PACKAGES}"
9 PACKAGES = "\
10     packagegroup-agl-demo-platform \
11     packagegroup-agl-demo-platform-devel \
12     "
13
14 ALLOW_EMPTY:${PN} = "1"
15
16 RDEPENDS:${PN} += "\
17     packagegroup-agl-image-ivi \
18     "
19
20 RDEPENDS:${PN} += "\
21     packagegroup-agl-profile-graphical-qt5 \
22     packagegroup-hmi-framework \
23     packagegroup-agl-demo \
24     "
25
26 AGL_APPS = " \
27     dashboard \
28     hvac \
29     ondemandnavi \
30     settings \
31     mediaplayer \
32     messaging \
33     phone \
34     radio \
35     "
36
37 # Cluster demo support.
38 CLUSTER_SUPPORT_PACKAGES = " \
39         tbtnavi \
40         cluster-demo-network-config \
41 "
42 CLUSTER_SUPPORT = "${@bb.utils.contains("AGL_FEATURES", "agl-cluster-demo-support", "${CLUSTER_SUPPORT_PACKAGES}", "",d)}"
43
44 # Hook for demo platform configuration
45 # ATM used for:
46 # 1) Adding udev configuration and scripts for supporting USB attached
47 #    I2C devices for RTC and HVAC LED support.
48 DEMO_UNIT_CONF ?= "demo-i2c-udev-conf"
49
50 # Preload only if agl-demo-preload is set
51 DEMO_PRELOAD = "${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "${DEMO_UNIT_CONF}", "",d)}"
52
53 RDEPENDS:${PN}:append = " \
54     launcher \
55     qtquickcontrols2-agl \
56     qtquickcontrols2-agl-style \
57     ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'unzip mpc' , '', d)} \
58     ${AGL_APPS} \
59     ${CLUSTER_SUPPORT} \
60     ${DEMO_PRELOAD} \
61     "