6fec1fc5c6ae02d443f6e29da314784fd35eee10
[AGL/meta-agl-demo.git] / recipes-platform / packagegroups / packagegroup-agl-demo-platform.bb
1 SUMMARY = "The software for DEMO platform of AGL IVI profile"
2 DESCRIPTION = "A set of packages belong to AGL Demo Platform"
3
4 LICENSE = "MIT"
5
6 inherit packagegroup
7
8 PROVIDES = "${PACKAGES}"
9 PACKAGES = "\
10     packagegroup-agl-demo-platform \
11     packagegroup-agl-demo-platform-devel \
12     "
13
14 ALLOW_EMPTY:${PN} = "1"
15
16 RDEPENDS:${PN} += "\
17     packagegroup-agl-image-ivi \
18     "
19
20 RDEPENDS:${PN} += "\
21     packagegroup-agl-profile-graphical-qt5 \
22     packagegroup-hmi-framework \
23     packagegroup-agl-demo \
24     "
25
26 AGL_APPS = " \
27     dashboard \
28     hvac \
29     mediaplayer \
30     virtual/navigation \
31     phone \
32     poiapp \
33     radio \
34     settings \
35     messaging \
36     ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'taskmanager' , '', d)} \
37     ${@bb.utils.contains('AGL_FEATURES', 'waltham-remoting', 'waltham waltham-transmitter-plugin' , '', d)} \
38     virtual/mixer \
39     virtual/qtwayland-config \
40     "
41
42 QTAGLEXTRAS = " libqtappfw"
43
44 # add support for websocket in Qt and QML
45 QTAGLEXTRAS:append = " qtwebsockets qtwebsockets-qmlplugins"
46 #PREFERRED_PROVIDER_virtual/webruntime = "web-runtime"
47
48 # Cluster demo support.
49 # ATM no cluster map viewer is supported with the older navigation application.
50 MAPVIEWER = "${@bb.utils.contains("PREFERRED_RPROVIDER_virtual/navigation", "ondemandnavi", "tbtnavi", "",d)}"
51 CLUSTER_SUPPORT_PACKAGES = " \
52         ${MAPVIEWER} \
53         cluster-demo-network-config \
54         cluster-lin-bridging-config \
55         cluster-demo-simulator \
56 "
57 CLUSTER_SUPPORT = "${@bb.utils.contains("AGL_FEATURES", "agl-cluster-demo-support", "${CLUSTER_SUPPORT_PACKAGES}", "",d)}"
58
59 DEMO_UNIT_CONF ?= ""
60 # Hook for demo platform configuration
61 # ATM used for:
62 # 1) Adding udev configuration and scripts for supporting USB attached
63 #    I2C devices for RTC and HVAC LED support.
64 DEMO_UNIT_CONF += " demo-i2c-udev-conf "
65
66 # Preload only if agl-demo-preload is set
67 DEMO_PRELOAD = "${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", " ${DEMO_UNIT_CONF} poiapp-api-key", "",d)}"
68
69 RDEPENDS:${PN}:append = " \
70     weston-ini-conf \
71     qtquickcontrols2-agl \
72     qtquickcontrols2-agl-style \
73     ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'unzip' , '', d)} \
74     ${AGL_APPS} \
75     ${QTAGLEXTRAS} \
76     ${CLUSTER_SUPPORT} \
77     ${DEMO_PRELOAD} \
78     "
79
80 # NOTE: Currently no coverage versions for the application widgets,
81 #       they should be added here when available.
82 #       Also, the navigation and mixer debug widgets are currently
83 #       specified explicitly, as there's no simple way to derive their
84 #       names from the virtual/ RPROVIDES at present.
85 RDEPENDS:${PN}-devel = " \
86     packagegroup-hmi-framework-devel \
87     dashboard-dbg \
88     hvac-dbg \
89     mediaplayer-dbg \
90     mixer-dbg \
91     phone-dbg \
92     ondemandnavi-dbg \
93     poiapp-dbg \
94     radio-dbg \
95     settings-dbg \
96     messaging-dbg \
97     taskmanager-dbg \
98     "