Add udev rules and scripts for demo platform configuration
[AGL/meta-agl-demo.git] / recipes-platform / packagegroups / packagegroup-agl-demo-platform.bb
1 SUMMARY = "The software for DEMO platform of AGL IVI profile"
2 DESCRIPTION = "A set of packages belong to AGL Demo Platform"
3
4 LICENSE = "MIT"
5
6 inherit packagegroup
7
8 PACKAGES = "\
9     packagegroup-agl-demo-platform \
10     "
11
12 ALLOW_EMPTY_${PN} = "1"
13
14 RDEPENDS_${PN} += "\
15     packagegroup-agl-image-ivi \
16     "
17
18 RDEPENDS_${PN} += "\
19     packagegroup-agl-profile-graphical-qt5 \
20     packagegroup-agl-demo \
21     "
22
23 MOST_DRIVERS = " \
24     most \
25     "
26 MOST_DRIVERS_append_m3ulcb = " sllin"
27
28 # HVAC dependencies depend on drivers above
29 MOST_HVAC = " "
30 MOST_HVAC_append = " \
31     ${MOST_DRIVERS} \
32     unicens-config \
33     agl-service-unicens \
34     "
35
36 # @Chris: This needs to be checked!
37 MOST_HVAC_dra7xx-evm = ""
38 MOST_HVAC_dragonboard-410c = ""
39
40 AGL_APPS = " \
41     dashboard \
42     hvac \
43     mediaplayer \
44     virtual/mixer  \
45     virtual/navigation \
46     phone \
47     poiapp \
48     radio \
49     settings \
50     high-level-viwi-service \
51     agl-service-signal-composer \
52     low-can-demo \
53     "
54
55 AGL_APIS = " \
56     libnaviapi-agl \
57     "
58
59 QTAGLEXTRAS = "${@bb.utils.contains("DISTRO_FEATURES", "agl-hmi-framework", " qtaglextras", "",d)}"
60
61 # mapviewer and mapviewer-demo are required for AGL cluster demo
62 MAPVIEWER = "${@bb.utils.contains("DISTRO_FEATURES", "agl-cluster-demo-support", " mapviewer mapviewer-demo", "",d)}"
63
64 # Preload navigation maps and poi API key for demo if requested
65 DEMO_MAPS_LOCALE ?= "uk"
66 DEMO_PRELOAD = "${@bb.utils.contains("DISTRO_FEATURES", "agl-demo-preload", " navigation-maps-${DEMO_MAPS_LOCALE} poiapp-api-key", "",d)}"
67
68 # Hook for demo platform configuration
69 # ATM used for:
70 # 1) Adding udev configuration and scripts for supporting USB attached
71 #    I2C devices for RTC and HVAC LED support.
72 # 2) Adding udev configuration and script for detecting Fiberdyne MOST
73 #    attached amp and installing the required 4A HAL.
74 # 3) Disabling btwilink module on M3ULCB + Kingfisher by default.  To
75 #    re-enable, set DEMO_ENABLE_BTWILINK to "true" in local.conf/site.conf.
76 DEMO_ENABLE_BTWILINK ?= ""
77 DEMO_PLATFORM_CONF = " \
78     demo-i2c-udev-conf \
79     demo-most-udev-conf \
80 "
81 DEMO_PLATFORM_CONF_append_m3ulcb = "${@bb.utils.contains("DEMO_ENABLE_BTWILINK", "true", "", " btwilink-disable-conf", d)}"
82
83 RDEPENDS_${PN}_append = " \
84     qtquickcontrols2-agl \
85     qtquickcontrols2-agl-style \
86     linux-firmware-ralink \
87     ${MOST_HVAC} \
88     ${AGL_APPS} \
89     ${AGL_APIS} \
90     ${QTAGLEXTRAS} \
91     ${MAPVIEWER} \
92     ${DEMO_PRELOAD} \
93     ${DEMO_PLATFORM_CONF} \
94     "