Remove KUKSA.val server from Flutter images
[AGL/meta-agl-demo.git] / recipes-platform / packagegroups / packagegroup-agl-demo-platform-flutter.bb
1 SUMMARY = "The software for Flutter Demo platform of AGL IVI profile"
2 DESCRIPTION = "A set of packages for AGL Flutter Demo Platform"
3
4 LICENSE = "MIT"
5
6 inherit packagegroup
7
8 PROVIDES = "${PACKAGES}"
9 PACKAGES = "\
10     packagegroup-agl-demo-platform-flutter \
11     "
12
13 RDEPENDS:${PN} += "\
14     packagegroup-agl-image-ivi \
15     packagegroup-agl-kuksa-val-databroker \
16     packagegroup-agl-demo \
17     "
18
19 AGL_APPS = " \
20     flutter-dashboard \
21     flutter-hvac \
22     ondemandnavi \
23     settings \
24     mediaplayer \
25     messaging \
26     phone \
27     radio \
28     "
29
30 RDEPENDS:${PN}:append = " \
31     agl-compositor \
32     flutter-auto \
33     flutter-homescreen \
34     qtquickcontrols2-agl \
35     qtquickcontrols2-agl-style \
36     ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'unzip mpc' , '', d)} \
37     ${AGL_APPS} \
38     psplash-portrait-config \
39     "