c414adf47a63f4117aa321013bb697bfa36c934e
[AGL/meta-agl-demo.git] / recipes-platform / packagegroups / packagegroup-agl-cluster-demo-platform.bb
1 SUMMARY = "The software for demo platform of AGL cluster profile"
2 DESCRIPTION = "A set of packages belong to AGL Cluster Demo Platform"
3
4 LICENSE = "MIT"
5
6 inherit packagegroup
7
8 PACKAGES = "\
9     packagegroup-agl-cluster-demo-platform \
10     "
11
12 ALLOW_EMPTY:${PN} = "1"
13
14 RDEPENDS:${PN} += "\
15     packagegroup-agl-profile-cluster-qt5 \
16     packagegroup-agl-ttf-fonts \
17     packagegroup-agl-source-han-sans-ttf-fonts \
18     packagegroup-agl-networking \
19     "
20
21 AGL_APPS = " \
22     cluster-dashboard \
23     cluster-receiver \
24     qt-cluster-receiver \
25     "
26
27 RDEPENDS:${PN}:append = " \
28     can-utils \
29     ${AGL_APPS} \
30 "