681a043706399721286c3483aac1829d48786304
[AGL/meta-agl-demo.git] / recipes-platform / packagegroups / packagegroup-agl-cluster-demo-platform.bb
1 SUMMARY = "The software for demo platform of AGL cluster profile"
2 DESCRIPTION = "A set of packages belong to AGL Cluster Demo Platform"
3
4 LICENSE = "MIT"
5
6 inherit packagegroup
7
8 PACKAGES = "\
9     packagegroup-agl-cluster-demo-platform \
10     "
11
12 ALLOW_EMPTY:${PN} = "1"
13
14 RDEPENDS:${PN} += "\
15     packagegroup-agl-profile-cluster-qt5 \
16     packagegroup-agl-ttf-fonts \
17     packagegroup-agl-source-han-sans-ttf-fonts \
18     packagegroup-agl-networking \
19     "
20
21
22 AGL_APPS = " \
23     cluster-dashboard \
24     cluster-receiver \
25     qt-cluster-receiver \
26     "
27
28 AGL_APIS = " \
29     agl-service-can-low-level \
30     agl-service-gps \
31     agl-service-signal-composer \
32     "
33
34 RDEPENDS:${PN}:append = " \
35     hmi-debug \
36     can-utils \
37     linux-firmware-ralink \
38     ${AGL_APPS} \
39     ${AGL_APIS} \
40 "