SPEC-3723: restructure meta-agl-demo
[AGL/meta-agl-demo.git] / recipes-platform / packagegroups / packagegroup-agl-cluster-demo-platform.bb
1 SUMMARY = "The software for demo platform of AGL cluster profile"
2 DESCRIPTION = "A set of packages belong to AGL Cluster Demo Platform"
3
4 LICENSE = "MIT"
5
6 inherit packagegroup
7
8 PACKAGES = "\
9     packagegroup-agl-cluster-demo-platform \
10     "
11
12 ALLOW_EMPTY_${PN} = "1"
13
14 RDEPENDS_${PN} += "\
15     packagegroup-agl-profile-cluster-qt5 \
16     packagegroup-agl-ttf-fonts \
17     packagegroup-agl-source-han-sans-ttf-fonts \
18     packagegroup-agl-networking \
19     "
20
21
22 AGL_APPS = " \
23     cluster-dashboard \
24     cluster-receiver \
25     qt-cluster-receiver \
26     "
27
28 AGL_APIS = " \
29     agl-service-can-low-level \
30     agl-service-gps \
31     agl-service-signal-composer \
32     "
33
34 DEMO_PRELOAD = "${@bb.utils.contains("DISTRO_FEATURES", "agl-cluster-demo-preload", "cluster-dashboard-demo-config", "",d)}"
35
36 RDEPENDS_${PN}_append = " \
37     hmi-debug \
38     can-utils \
39     linux-firmware-ralink \
40     ${AGL_APPS} \
41     ${AGL_APIS} \
42     ${DEMO_PRELOAD} \
43 "