151245d5decae7d7b9af49c9d5d946b312c8dafe
[AGL/meta-agl-demo.git] / recipes-platform / packagegroups / packagegroup-agl-appfw-native-qt5.bb
1 SUMMARY = "Qt5 for native GUI framework of AGL IVI profile"
2 DESCRIPTION = "A set of Qt5 packages which required by Native App Fw Subsystem"
3
4 LICENSE = "MIT"
5
6 inherit packagegroup
7
8 PACKAGES = "\
9     packagegroup-agl-appfw-native-qt5 \
10     "
11
12 #ALLOW_EMPTY:${PN} = "1"
13
14 RDEPENDS:${PN} += "\
15     qtbase \
16     qtbase-dev \
17     qtbase-plugins \
18     qtbase-staticdev \
19     qtbase-tools \
20     qtdeclarative \
21     qtdeclarative-qmlplugins \
22     qtdeclarative-tools \
23     qtcharts \
24     qtwayland \
25     qtwayland-plugins \
26     qtwayland-tools \
27     qtgraphicaleffects-qmlplugins \
28     qtvirtualkeyboard \
29     "