a3efec425ebd98f900de2b0743c7511837997ed3
[AGL/meta-agl-demo.git] / recipes-platform / images / agl-telematics-demo-platform-crosssdk.bb
1 SUMMARY = "Cross SDK of AGL Distribution for telematics profile Demo"
2
3 DESCRIPTION = "SDK image for AGL Distribution for Telematics profile Demo. \
4 It includes the full meta-toolchain, plus developement headers and libraries \
5 to form a standalone cross SDK."
6
7 require agl-telematics-demo-platform.bb
8
9 LICENSE = "MIT"
10
11 IMAGE_FEATURES:append = " dev-pkgs"
12 IMAGE_INSTALL:append = " kernel-dev kernel-devsrc"
13
14 inherit populate_sdk
15
16 # Task do_populate_sdk and do_rootfs can't be exec simultaneously.
17 # Both exec "createrepo" on the same directory, and so one of them
18 # can failed (randomly).
19 addtask do_populate_sdk after do_rootfs
20
21 TOOLCHAIN_HOST_TASK:append = " nativesdk-perl-modules "