490047635333d0f02704f6088c3537054548d805
[AGL/meta-agl-demo.git] / recipes-platform / images / agl-ivi-demo-platform-crosssdk.bb
1 SUMMARY = "Cross SDK of Full AGL Distribution for IVI profile"
2
3 DESCRIPTION = "SDK image for full AGL Distribution for IVI profile. \
4 It includes the full meta-toolchain, plus developement headers and libraries \
5 to form a standalone cross SDK."
6
7
8 # add packages for demo platform (include demo apps) here
9 IMAGE_INSTALL:append = " \
10     packagegroup-agl-demo-platform \
11     "
12
13 LICENSE = "MIT"
14
15 #require agl-image-graphical-qt5-crosssdk.inc
16 require recipes-platform/images/agl-image-weston.inc
17 require recipes-platform/images/agl-image-minimal-crosssdk.inc
18
19 # Add wayland-scanner to SDK (SPEC-945)
20 # Use TOOLCHAIN_HOST_TASK instead of adding to the packagegroup
21 # wayland-scanner is in nativesdk-wayland-dev !
22 # option: add also nativesdk-qtwayland-tools
23 TOOLCHAIN_HOST_TASK:append = " nativesdk-wayland nativesdk-wayland-dev"
24
25 TOOLCHAIN_HOST_TASK:append = " nativesdk-perl-modules "
26
27 # Add qtwaylandscanner to the SDK
28 TOOLCHAIN_HOST_TASK:append = " nativesdk-qtwayland-tools "
29
30
31 # Task do_populate_sdk and do_rootfs can't be exec simultaneously.
32 # Both exec "createrepo" on the same directory, and so one of them
33 # can failed (randomly).
34 addtask do_populate_sdk after do_rootfs
35
36 inherit populate_sdk populate_sdk_qt5
37
38 # Task do_populate_sdk and do_rootfs can't be exec simultaneously.
39 # Both exec "createrepo" on the same directory, and so one of them
40 # can failed (randomly).
41 addtask do_populate_sdk after do_rootfs
42
43 # Add gcc-sanitizers to support building applications using the SDK with
44 # AddressSanitizer support to detect use-after-frees along with other
45 # memory issue.
46 TOOLCHAIN_TARGET_TASK += "gcc-sanitizers"
47
48 TOOLCHAIN_TARGET_TASK += "waltham-dev"
49
50
51 TOOLCHAIN_HOST_TASK += " \
52     nativesdk-lua \
53     "
54
55 # Required dependencies for app and test builds
56 TOOLCHAIN_TARGET_TASK += " \
57     lua-dev \
58     lua-staticdev \
59     "