3e3d478d3866c65954c8901109369e6ed58d06c4
[AGL/meta-agl-demo.git] / recipes-platform / images / agl-ivi-demo-platform-crosssdk.bb
1 require agl-ivi-demo-platform.bb
2
3 SUMMARY = "Cross SDK of Full AGL Distribution for IVI profile"
4
5 DESCRIPTION = "SDK image for full AGL Distribution for IVI profile. \
6 It includes the full meta-toolchain, plus developement headers and libraries \
7 to form a standalone cross SDK."
8
9 require recipes-platform/images/agl-image-minimal-crosssdk.inc
10
11 # Add wayland-scanner to SDK (SPEC-945)
12 # Use TOOLCHAIN_HOST_TASK instead of adding to the packagegroup
13 # wayland-scanner is in nativesdk-wayland-dev !
14 # option: add also nativesdk-qtwayland-tools
15 TOOLCHAIN_HOST_TASK:append = " nativesdk-wayland nativesdk-wayland-dev"
16
17 TOOLCHAIN_HOST_TASK:append = " nativesdk-perl-modules "
18
19 # Add qtwaylandscanner to the SDK
20 TOOLCHAIN_HOST_TASK:append = " nativesdk-qtwayland-tools "
21
22 # add grpc for building natively for grpc_cpp_plugin
23 TOOLCHAIN_HOST_TASK:append = " nativesdk-grpc nativesdk-grpc-dev "
24 # Task do_populate_sdk and do_rootfs can't be exec simultaneously.
25 # Both exec "createrepo" on the same directory, and so one of them
26 # can failed (randomly).
27 addtask do_populate_sdk after do_rootfs
28
29 inherit populate_sdk populate_sdk_qt5
30
31 # Task do_populate_sdk and do_rootfs can't be exec simultaneously.
32 # Both exec "createrepo" on the same directory, and so one of them
33 # can failed (randomly).
34 addtask do_populate_sdk after do_rootfs
35
36 # Add gcc-sanitizers to support building applications using the SDK with
37 # AddressSanitizer support to detect use-after-frees along with other
38 # memory issue.
39 TOOLCHAIN_TARGET_TASK += "gcc-sanitizers"
40
41
42 TOOLCHAIN_HOST_TASK += " \
43     nativesdk-lua \
44 "
45
46 # Required dependencies for app and test builds
47 TOOLCHAIN_TARGET_TASK += " \
48     lua-dev \
49     lua-staticdev \
50 "