agl-demo-control-panel: add recipe and image
[AGL/meta-agl-demo.git] / recipes-platform / images / agl-ivi-demo-control-panel.bb
1 require recipes-platform/images/agl-image-weston.bb
2
3 SUMMARY = "AGL demo control panel image"
4
5 IMAGE_FEATURES += "splash package-management ssh-server-openssh"
6
7 # NOTE: The client key and certificate in kuksa-certificates-agl-client
8 #       seem required by kuksa-client at the moment even though client
9 #       certification has been deprecated upstream, this needs further
10 #       investigation so it can be dropped from the image.
11 #   
12 IMAGE_KUKSA_PACKAGES = " \
13     kuksa-client \
14     kuksa-certificates-agl-ca \
15     kuksa-certificates-agl-client \
16 "
17
18 IMAGE_INSTALL += "\
19     packagegroup-agl-networking \
20     weston-ini-conf-landscape \
21     weston-agl-driver-conf \
22     ${IMAGE_KUKSA_PACKAGES} \
23     agl-demo-control-panel \
24     qtwayland \
25     qtwayland-plugins \
26     qtwayland-qmlplugins \
27 "