Prepare master for new framework integration
[AGL/meta-agl-demo.git] / recipes-platform / images / agl-image-graphical-qt5-crosssdk.bb
1 SUMMARY = "Cross SDK of Full AGL Distribution for IVI profile"
2
3 DESCRIPTION = "SDK image for full AGL Distribution for IVI profile. \
4 It includes the full meta-toolchain, plus developement headers and libraries \
5 to form a standalone cross SDK."
6
7 #require agl-image-graphical-qt5.bb
8 require recipes-platform/images/agl-image-weston.inc
9
10
11 LICENSE = "MIT"
12
13 require recipes-platform/images/agl-image-minimal-crosssdk.inc
14
15 # Add wayland-scanner to SDK (SPEC-945)
16 # Use TOOLCHAIN_HOST_TASK instead of adding to the packagegroup
17 # wayland-scanner is in nativesdk-wayland-dev !
18 # option: add also nativesdk-qtwayland-tools
19 TOOLCHAIN_HOST_TASK:append = " nativesdk-wayland nativesdk-wayland-dev"
20
21 TOOLCHAIN_HOST_TASK:append = " nativesdk-perl-modules "
22
23 # Add qtwaylandscanner to the SDK
24 TOOLCHAIN_HOST_TASK:append = " nativesdk-qtwayland-tools "
25
26
27 inherit populate_sdk populate_sdk_qt5
28
29 # Task do_populate_sdk and do_rootfs can't be exec simultaneously.
30 # Both exec "createrepo" on the same directory, and so one of them
31 # can failed (randomly).
32 addtask do_populate_sdk after do_rootfs