Add switch on/off script for cluster demo
[AGL/meta-agl-demo.git] / recipes-platform / images / agl-demo-platform.bb
1 # Base image
2 require recipes-ivi/images/agl-image-ivi.inc
3
4 DESCRIPTION = "AGL Demo Platform image currently contains a simple HMI and \
5 demos."
6
7 IMAGE_FEATURES_append = " \
8     "
9
10 # add packages for demo platform (include demo apps) here
11 IMAGE_INSTALL_append = " \
12     packagegroup-agl-core \
13     packagegroup-agl-ivi \
14     packagegroup-ivi-common-core \
15     packagegroup-agl-demo-platform \
16     "
17
18 # fonts
19 IMAGE_TTF_FONTS = " \
20     ttf-bitstream-vera \
21     ttf-dejavu-sans \
22     ttf-dejavu-sans-mono \
23     ttf-dejavu-serif \
24     "
25
26 # add packages for CES2017 demo
27 # Only for porter as these kernel module sources
28 # are for the 3.10.x kernel only
29 MOST_DRIVERS = " "
30 MOST_DRIVERS_append_porter = " \
31     aim-cdev \
32     aim-network \
33     aim-sound \
34     aim-v4l2 \
35     hdm-dim2 \
36     hdm-i2c \
37     hdm-usb \
38     mocca-usb \
39     mostcore \
40     "
41
42 # HVAC dependencies depend on drivers above
43 IMAGE_MOST_HVAC = " "
44 IMAGE_MOST_HVAC_append_porter = " \
45     ${MOST_DRIVERS} \
46     unicens \
47     vod-server \
48     "
49
50 # can-lin is a binary and only for porter :(
51 IMAGE_MOST_HVAC_append_porter = " \
52     can-lin \
53     "
54
55 # mapviewer and mapviewer-demo requires AGL CES2017 demo mock-up
56 IMAGE_MAPVIEWER = " "
57 IMAGE_MAPVIEWER_append_porter = " \
58     mapviewer \
59     mapviewer-demo \
60     "
61
62 IMAGE_AGL_APPS = " \
63     hvac \
64     mediaplayer \
65     mixer \
66     navigation \
67     settings \
68     "
69
70 IMAGE_INSTALL_append = " \
71     ces2017-demo \
72     linux-firmware-ath9k \
73     linux-firmware-ralink \
74     can-utils \
75     iproute2 \
76     python-curses \
77     dhcp-client \
78     navigation \
79     poiapp \
80     ${IMAGE_MAPVIEWER} \
81     ${IMAGE_MOST_HVAC} \
82     ${IMAGE_AGL_APPS} \
83     ${IMAGE_TTF_FONTS} \
84     "