Add firmware for CES 2017 demo hardware
[AGL/meta-agl-demo.git] / recipes-platform / images / agl-demo-platform.bb
1 # Base image
2 require recipes-ivi/images/agl-image-ivi.inc
3
4 DESCRIPTION = "AGL Demo Platform image currently contains a simple HMI and \
5 demos."
6
7 IMAGE_FEATURES_append = " \
8     "
9
10 # add packages for demo platform (include demo apps) here
11 IMAGE_INSTALL_append = " \
12     packagegroup-agl-core \
13     packagegroup-agl-ivi \
14     packagegroup-ivi-common-core \
15     packagegroup-agl-demo-platform \
16     "
17
18 # fonts
19 IMAGE_TTF_FONTS = " \
20     ttf-bitstream-vera \
21     ttf-dejavu-sans \
22     ttf-dejavu-sans-mono \
23     ttf-dejavu-serif \
24     "
25
26 # add packages for CES2017 demo
27 IMAGE_INSTALL_append = " \
28     ces2017-demo \
29     linux-firmware-ath9k \
30     can-utils \
31     iproute2 \
32     python-curses \
33     dhcp-client \
34     climatecontrolplugin \
35     Navigation \
36     ${IMAGE_TTF_FONTS} \
37     "