Add kernel-devsrc to AGL demo platform SDK
[AGL/meta-agl-demo.git] / recipes-platform / images / agl-demo-platform-crosssdk.bb
1 SUMMARY = "Cross SDK of Full AGL Distribution for IVI profile"
2
3 DESCRIPTION = "SDK image for full AGL Distribution for IVI profile. \
4 It includes the full meta-toolchain, plus developement headers and libraries \
5 to form a standalone cross SDK."
6
7 require agl-demo-platform.bb
8
9 LICENSE = "MIT"
10
11 IMAGE_FEATURES_append = " dev-pkgs"
12 IMAGE_INSTALL_append = " kernel-dev kernel-devsrc"
13
14 inherit populate_sdk populate_sdk_qt5
15
16 # Task do_populate_sdk and do_rootfs can't be exec simultaneously.
17 # Both exec "createrepo" on the same directory, and so one of them
18 # can failed (randomly).
19 addtask do_populate_sdk after do_rootfs