3rd part of the layer/profile rework [2/2]
[AGL/meta-agl-demo.git] / recipes-platform / images / agl-demo-platform-crosssdk.bb
1 SUMMARY = "Cross SDK of Full AGL Distribution for IVI profile"
2
3 DESCRIPTION = "SDK image for full AGL Distribution for IVI profile. \
4 It includes the full meta-toolchain, plus developement headers and libraries \
5 to form a standalone cross SDK."
6
7 require agl-demo-platform.bb
8
9 LICENSE = "MIT"
10
11 IMAGE_FEATURES_append = " dev-pkgs"
12 IMAGE_INSTALL_append = " kernel-dev kernel-devsrc"
13
14 inherit populate_sdk populate_sdk_qt5
15
16 # Task do_populate_sdk and do_rootfs can't be exec simultaneously.
17 # Both exec "createrepo" on the same directory, and so one of them
18 # can failed (randomly).
19 addtask do_populate_sdk after do_rootfs
20
21 # native tools to support Chromium build inside SDK (SPEC-942)
22 TOOLCHAIN_HOST_TASK += " \
23     nativesdk-gn \
24     nativesdk-ninja \
25     nativesdk-gperf \
26     nativesdk-zlib \
27     nativesdk-xz \
28     nativesdk-nspr-dev \
29     nativesdk-nss-dev \
30     nativesdk-lua \
31     "
32
33 # required dependencies for Chromium build inside SDK (SPEC-942)
34 TOOLCHAIN_TARGET_TASK += " \
35     pciutils-dev \
36     pulseaudio-dev \
37     cairo-dev \
38     nss-dev \
39     cups-dev \
40     gconf-dev \
41     libexif-dev \
42     pango-dev \
43     libdrm-dev  \
44     libssp-dev \
45     lua-dev \
46     lua-staticdev \
47     ${@bb.utils.contains('LICENSE_FLAGS_WHITELIST', 'commercial', 'ffmpeg-dev', '', d)} \
48     "
49
50 # Add wayland-scanner to SDK (SPEC-945)
51 # Use TOOLCHAIN_HOST_TASK instead of adding to the packagegroup
52 # wayland-scanner is in nativesdk-wayland-dev !
53 # option: add also nativesdk-qtwayland-tools
54 TOOLCHAIN_HOST_TASK_append = " nativesdk-wayland nativesdk-wayland-dev"
55
56 TOOLCHAIN_HOST_TASK_append = " nativesdk-perl-modules "