Add umock-c to crosssdk
[AGL/meta-agl-demo.git] / recipes-platform / images / agl-demo-platform-crosssdk.bb
1 SUMMARY = "Cross SDK of Full AGL Distribution for IVI profile"
2
3 DESCRIPTION = "SDK image for full AGL Distribution for IVI profile. \
4 It includes the full meta-toolchain, plus developement headers and libraries \
5 to form a standalone cross SDK."
6
7 require agl-demo-platform.bb
8
9 LICENSE = "MIT"
10
11 require recipes-platform/images/agl-image-graphical-qt5-crosssdk.inc
12
13 inherit populate_sdk populate_sdk_qt5
14
15 # Task do_populate_sdk and do_rootfs can't be exec simultaneously.
16 # Both exec "createrepo" on the same directory, and so one of them
17 # can failed (randomly).
18 addtask do_populate_sdk after do_rootfs
19
20 # Add mosquitto to support building the telematics demo application.
21 # This is currently required for CI, as it uses agl-demo-platform-crosssdk
22 # to build everything. An agenda item has been tabled for the May 2019 F2F
23 # meeting to discuss the path forward (separate versus superset SDKs), this
24 # should be reviewed after that.
25 TOOLCHAIN_TARGET_TASK += "mosquitto-dev"
26
27 # Add nlohmann-json to support building the speech services.
28 # Required until either the agl-speech-framework feature is added as a
29 # dependency of agl-demo, or the speech services are migrated into the
30 # core profile.
31 TOOLCHAIN_TARGET_TASK += "nlohmann-json-dev"
32
33 # Add libstdc++-staticdev to support building agl-service-voice-high or
34 # other users of the C++17 filesystem standard library feature.
35 # Can be removed upon upgrade to gcc 9.x, as it will no longer be necessary.
36 TOOLCHAIN_TARGET_TASK += "libstdc++-staticdev"
37
38 # Add gcc-sanitizers to support building applications using the SDK with
39 # AddressSanitizer support to detect use-after-frees along with other
40 # memory issue.
41 TOOLCHAIN_TARGET_TASK += "gcc-sanitizers"
42
43 # Add azure-iot-sdk-c to support building agl-service-cloudproxy and
44 # other users of Azure sdk.
45 TOOLCHAIN_TARGET_TASK += "azure-iot-sdk-c umock-c"