Explicitly add CA certificate package to cluster images
[AGL/meta-agl-demo.git] / recipes-platform / images / agl-cluster-demo-platform.bb
1 DESCRIPTION = "AGL Cluster Demo Platform image currently contains a simple cluster interface."
2
3 LICENSE = "MIT"
4
5 require recipes-platform/images/agl-image-compositor.bb
6
7 IMAGE_FEATURES += "splash package-management ssh-server-openssh"
8
9 inherit features_check
10
11 REQUIRED_DISTRO_FEATURES = "wayland"
12
13 # Break out KUKSA.val packages, as demo unit configuration
14 # points at KUKSA.val server on the IVI board in full demo
15 # builds with the "agl-demo-preload" feature enabled.
16 KUKSA_DATABROKER_PACKAGES = " \
17     packagegroup-agl-kuksa-val-databroker \
18     ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'packagegroup-agl-kuksa-val-databroker-devel' , '', d)} \
19 "
20
21 # add packages for cluster demo platform (include demo apps) here
22 IMAGE_INSTALL += " \
23     packagegroup-agl-cluster-demo-platform \
24     kuksa-certificates-agl-ca \
25     ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "cluster-demo-config", "", d)} \
26     ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "weston-ini-conf-landscape-inverted", "weston-ini-conf-landscape", d)} \
27     ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "", "${KUKSA_DATABROKER_PACKAGES}", d)} \
28     ${@bb.utils.contains("AGL_FEATURES", "AGLCI", "qemu-set-display", "", d)} \
29     "