Add KUKSA.val databroker image features
[AGL/meta-agl-demo.git] / recipes-platform / images / agl-cluster-demo-platform-flutter.bb
1 SUMMARY = "Baseline Flutter Image for Release"
2
3 LICENSE = "MIT"
4
5 require recipes-platform/images/agl-image-compositor.bb
6 require agl-demo-features.inc
7
8 IMAGE_FEATURES += "splash package-management ssh-server-openssh"
9
10 # KUKSA.val databroker is not installed with "agl-demo-preload"
11 # feature enabled, since demo unit configuration points at the
12 # databroker on the IVI board in that setup.
13 IMAGE_FEATURES += " \
14     kuksa-val-databroker-client \
15     ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "", "kuksa-val-databroker", d)} \
16 "
17
18 # Generic
19 IMAGE_INSTALL += "\
20     ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "psplash-inverted-config", "", d)} \
21     ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "weston-ini-conf-landscape-inverted", "weston-ini-conf-landscape", d)} \
22     \
23     packagegroup-agl-networking \
24     cluster-receiver \
25     \
26     simple-can-simulator \
27     "
28
29 # Flutter
30 IMAGE_INSTALL += "\
31     flutter-cluster-dashboard \
32     ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "flutter-cluster-dashboard-conf-demo", "flutter-cluster-dashboard-conf", d)} \
33     cluster-demo-config-flutter \
34     flutter-auto \
35     "
36
37 CLANGSDK = "1"