8251272cb3cf7bc68a718238f9f3ef34291a82be
[AGL/meta-agl-demo.git] / recipes-platform / images / agl-cluster-demo-platform-crosssdk.bb
1 SUMMARY = "Cross SDK of AGL Distribution for Cluster profile Demo"
2
3 DESCRIPTION = "SDK image for AGL Distribution for Cluster profile Demo. \
4 It includes the full meta-toolchain, plus developement headers and libraries \
5 to form a standalone cross SDK."
6
7 require agl-cluster-demo-platform.bb
8
9 LICENSE = "MIT"
10
11 IMAGE_FEATURES:append = " dev-pkgs"
12 IMAGE_INSTALL:append = " kernel-dev kernel-devsrc"
13
14 inherit populate_sdk populate_sdk_qt5
15
16 # Task do_populate_sdk and do_rootfs can't be exec simultaneously.
17 # Both exec "createrepo" on the same directory, and so one of them
18 # can failed (randomly).
19 addtask do_populate_sdk after do_rootfs
20
21 # Add wayland-scanner to SDK (SPEC-945)
22 # Use TOOLCHAIN_HOST_TASK instead of adding to the packagegroup
23 # wayland-scanner is in nativesdk-wayland-dev !
24 # option: add also nativesdk-qtwayland-tools
25 TOOLCHAIN_HOST_TASK:append = " nativesdk-wayland nativesdk-wayland-dev"
26
27 TOOLCHAIN_HOST_TASK:append = " nativesdk-perl-modules "