2nd part of the layer/profile rework [2/2]
[AGL/meta-agl-demo.git] / recipes-openivi / openivi-html5 / openivi-html5_git.bb
1 DESCRIPTION = "OpenIVI Mobility HTML5 environment"
2 HOMEPAGE = "https://openivimobility.github.io/"
3 SECTION = "base"
4 LICENSE = "GPLv2+"
5 LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4641e94ec96f98fabc56ff9cc48be14b"
6 FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
7
8 SRC_URI = " \
9         git://github.com/openivimobility/openivi-html5.git;branch=master;tag=0b370eea8c7c852365bd717013a523b678abbdba \
10         file://openivi-html5.sh \
11         file://openivi-html5.service \
12 "
13
14 inherit pkgconfig cmake_qt5 externalsrc systemd
15 PV = "0.1"
16
17 S = "${WORKDIR}/git"
18
19 RDEPENDS_${PN} = "qtbase qtwebkit inputeventmanager windowmanager"
20 DEPENDS = "qtbase-native qtbase qtwebkit"
21
22 EXTRA_OECMAKE = " -DCMAKE_DISABLE_FIND_PACKAGE_X11=TRUE "
23
24 FILES_${PN} = "/usr/bin/openivi-html5 /usr/share/openivi/*"
25
26 do_install() {
27   install -d ${D}${bindir}
28   install -m 0755 openivi-html5 ${D}${bindir}
29
30   install -d ${D}${datadir}/openivi/
31   cp -r ${S}/example ${D}${datadir}/openivi/
32
33   install -p -D ${WORKDIR}/openivi-html5.sh ${D}${bindir}/openivi-html5.sh
34
35   if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
36     install -d ${D}${systemd_user_unitdir}
37     install -p -D ${WORKDIR}/openivi-html5.service ${D}${systemd_user_unitdir}/openivi-html5.service
38     install -d ${D}${sysconfdir}/systemd/user/default.target.wants
39     ln -sf ${systemd_user_unitdir}/openivi-html5.service ${D}${sysconfdir}/systemd/user/default.target.wants
40   fi
41 }
42
43 FILES_${PN} += " ${prefix}/bin/openivi-html5.sh ${systemd_user_unitdir} ${sysconfdir}"