cd52b68ad359478277b4640f1b7393c2a5cdd4a0
[AGL/meta-agl-demo.git] / recipes-multimedia / module-router / module-router_git.bb
1 DESCRIPTION = "Pulseaudio router module"
2 HOMEPAGE = "https://github.com/tisogai/module-router"
3 LICENSE = "LGPLv2"
4 SECTION = "multimedia"
5 DEPENDS = "pulseaudio"
6
7 LIC_FILES_CHKSUM = "file://LICENSE;md5=fc178bcd425090939a8b634d1d6a9594"
8
9 SRC_URI = " \
10     git://github.com/tisogai/module-router.git;protocol=https;branch=master \
11   "
12
13 SRCREV = "8104a3174e6f54ace53066ab1797d9b9bd2bdf63"
14
15 S = "${WORKDIR}/git"
16 inherit cmake
17 OECMAKE_CXX_FLAGS += "-std=c++11"
18
19 # NOTE: The specific product should have a separate customtypes.xsd
20 # and should be appended to FILES_${PN} in product specific
21 # audiomanager-generic-controller_git.bbappend
22 FILES_${PN} = " \
23     ${libdir}/pulse-*/modules/module-router.so \
24 "
25
26
27 FILES_${PN}-dbg += " \
28     ${libdir}/pulse-*/modules/.debug/module-router.so \
29 "
30
31