recipes-kernel: add MOST driver kernel modules
[AGL/meta-agl-demo.git] / recipes-kernel / mostcore / mostcore.bb
1 DESCRIPTION = "Example of how to build an external Linux kernel module"
2 LICENSE = "GPLv2"
3 LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
4                     file://core.c;md5=a47d4154c42744ac4ea233372ddf975d \
5                    "  
6
7 inherit module
8
9 PR = "r0"
10 PV = "0.1"
11
12 SRC_URI = "file://Makefile \
13            file://core.c \
14            file://mostcore.h \
15            file://COPYING \
16           "
17
18 S = "${WORKDIR}"
19
20 # The inherit of module.bbclass will automatically name module packages with
21 # "kernel-module-" prefix as required by the oe-core build environment.