Make sure app recipes use the release versions
[AGL/meta-agl-demo.git] / recipes-kernel / most / most.bb
1 DESCRIPTION = "Build MOST driver"
2 LICENSE = "GPLv2"
3 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
4
5 inherit module
6
7 PV = "0.1"
8
9 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/most;protocol=https;branch=dab"
10 SRC_URI_append_porter = " file://0001-aim-network-3.10.31-ltsi-backport.patch \
11                            file://0001-aim-sound-3.10.31-ltsi-backport.patch \
12                          "
13 S = "${WORKDIR}/git/driver"
14 SRCREV = "c52aecbce20ccc47ee91a9bd33cf413772b3487a"
15 SRCREV_dab = "refs/tags/${DISTRO_BRANCH_VERSION_TAG}"
16
17
18 # The inherit of module.bbclass will automatically name module packages with
19 # "kernel-module-" prefix as required by the oe-core build environment.
20
21 do_install_append () {
22     # modprobe automatically at boot
23     if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
24         install -d ${D}${sysconfdir}/modules-load.d
25         echo "aim_cdev" > ${D}${sysconfdir}/modules-load.d/aim_cdev.conf
26         echo "aim_sound" > ${D}${sysconfdir}/modules-load.d/aim_sound.conf
27         echo "aim_network" > ${D}${sysconfdir}/modules-load.d/aim_network.conf
28         echo "aim_v4l2" > ${D}${sysconfdir}/modules-load.d/aim_v4l2.conf
29         echo "hdm_i2c" > ${D}${sysconfdir}/modules-load.d/hdm_i2c.conf
30         echo "hdm_dim2" > ${D}${sysconfdir}/modules-load.d/hdm_dim2.conf
31         echo "hdm_usb" > ${D}${sysconfdir}/modules-load.d/hdm_usb.conf
32         echo "mostcore" > ${D}${sysconfdir}/modules-load.d/mostcore.conf
33     fi
34 }