recipes-kernel: most: update recipes
[AGL/meta-agl-demo.git] / recipes-kernel / most / most.bb
1 DESCRIPTION = "Build MOST driver"
2 LICENSE = "GPLv2"
3 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
4
5 inherit module
6
7 PV = "0.1"
8
9 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/most;protocol=https;branch=master"
10
11 S = "${WORKDIR}/git/driver"
12 SRCREV = "794e6dc552e626eb6dd506baf941873414d9ef73"
13
14 # The inherit of module.bbclass will automatically name module packages with
15 # "kernel-module-" prefix as required by the oe-core build environment.
16
17 do_install_append () {
18     # modprobe automatically at boot
19     if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
20         install -d ${D}${sysconfdir}/modules-load.d
21         echo "aim_cdev" > ${D}${sysconfdir}/modules-load.d/aim_cdev.conf
22         echo "aim_sound" > ${D}${sysconfdir}/modules-load.d/aim_sound.conf
23         echo "aim_network" > ${D}${sysconfdir}/modules-load.d/aim_network.conf
24         echo "aim_v4l2" > ${D}${sysconfdir}/modules-load.d/aim_v4l2.conf
25         echo "hdm_i2c" > ${D}${sysconfdir}/modules-load.d/hdm_i2c.conf
26         echo "hdm_dim2" > ${D}${sysconfdir}/modules-load.d/hdm_dim2.conf
27         echo "hdm_usb" > ${D}${sysconfdir}/modules-load.d/hdm_usb.conf
28         echo "mostcore" > ${D}${sysconfdir}/modules-load.d/mostcore.conf
29     fi
30 }