Fix most compilation for YP 3.1.25 uprev
[AGL/meta-agl-demo.git] / recipes-kernel / most / most.bb
1 DESCRIPTION = "Build MOST driver"
2 LICENSE = "GPLv2"
3 LIC_FILES_CHKSUM = "file://mostcore/COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e"
4
5 inherit module
6
7 PV = "0.1"
8
9 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/most;protocol=https;branch=${AGL_BRANCH} \
10         file://0002-src-most-add-auto-conf-feature.patch \
11         file://0003-core-remove-kernel-log-for-MBO-status.patch \
12         file://0004-most-video-set-device_caps.patch \
13         file://0005-most-video-set-V4L2_CAP_DEVICE_CAPS-flag.patch \
14         file://0006-dim2-fix-startup-sequence.patch \
15         file://0007-dim2-use-device-tree.patch \
16         file://0008-dim2-read-clock-speed-from-the-device-tree.patch \
17         file://0009-dim2-use-device-for-coherent-memory-allocation.patch \
18         file://0010-backport-usb-setup-timer.patch \
19         file://0011-handle-snd_pcm_lib_mmap_vmalloc-removal.patch \
20         file://0012-Fix-build-with-5.4-kernel.patch \
21         file://0013-Fix-build-with-5.7-kernel.patch \
22         file://0014-Fix-build-with-5.9-kernel.patch \
23         file://0001-Fix-LINUX_VERSION_CODE-check-for-dim2_hdm.patch \
24         "
25
26 S = "${WORKDIR}/git/driver"
27 SRCREV = "e4dbbaf9e7652efaed0df3e0aab4464f5f228573"
28
29 KERNEL_MODULE_AUTOLOAD += "aim_cdev aim_sound aim_network aim_v4l2 hdm_i2c hdm_dim2 hdm_usb mostcore"