Update SRCREVs for 4.0.2 release
[AGL/meta-agl-demo.git] / recipes-kernel / mocca-usb / mocca-usb.bb
1 DESCRIPTION = "Build USB driver for MOCCA box"
2 LICENSE = "GPLv2"
3 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
4
5 inherit module
6
7 PV = "0.1"
8
9 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/can-lin/;protocol=https;branch=dab"
10 S = "${WORKDIR}/git/Usb-Driver"
11
12 SRCREV = "b330168fd3e8043795ab2b9574be12f91ddf0661"
13 SRCREV_dab = "refs/tags/${DISTRO_BRANCH_VERSION_TAG}"
14
15 # The inherit of module.bbclass will automatically name module packages with
16 # "kernel-module-" prefix as required by the oe-core build environment.
17
18 do_install_append () {
19     # modprobe automatically at boot
20     if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
21         install -d ${D}${sysconfdir}/modules-load.d
22         echo "mocca_usb" > ${D}${sysconfdir}/modules-load.d/mocca_usb.conf
23     fi
24 }