438117a49b9b7387b365baf69b467a5ab7de1131
[AGL/meta-agl-demo.git] / recipes-kernel / hdm-dim2 / hdm-dim2.bb
1 DESCRIPTION = "Example of how to build an external Linux kernel module"
2 LICENSE = "GPLv2"
3 LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
4                     file://dim2_hdm.c;md5=263233c0fde1611b5b416f415bd3594d \  
5                     file://dim2_hal.c;md5=9ae71bc76a4a056593eec2efc5703f50 \
6                     file://dim2_sysfs.c;md5=d66a0b6e9b3979d18653029d1cb4c362 \  
7                    "
8
9 inherit module
10
11 PR = "r0"
12 PV = "0.1"
13
14 SRC_URI = "file://Makefile \
15            file://../../mostcore/files/mostcore.h \
16            file://../../aim-network/files/networking.h \
17            file://dim2_hal.h \
18            file://dim2_hdm.h \
19            file://dim2_sysfs.h \
20            file://dim2_reg.h \
21            file://dim2_errors.h \
22            file://dim2_hdm.c \
23            file://dim2_hal.c \
24            file://dim2_sysfs.c \
25            file://COPYING \
26           "
27
28 S = "${WORKDIR}"
29
30 # The inherit of module.bbclass will automatically name module packages with
31 # "kernel-module-" prefix as required by the oe-core build environment.