Add packages to agl-demo-platform for CES2017 Demo
[AGL/meta-agl-demo.git] / recipes-kernel / aim-network / aim-network.bb
1 DESCRIPTION = "Example of how to build an external Linux kernel module"
2 LICENSE = "GPLv2"
3 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
4 #LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
5 #                  "  
6
7 inherit module
8
9 PV = "0.1"
10
11 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/most;protocol=https"
12
13 S = "${WORKDIR}/git/driver/${PN}"
14 SRCREV = "ad245bdd60434dd46d6461f585d49db1b3b0d75b"
15 #SRCREV = "${AUTOREV}"
16
17 # The inherit of module.bbclass will automatically name module packages with
18 # "kernel-module-" prefix as required by the oe-core build environment.
19
20 do_install_append () {
21     # modprobe automatically at boot
22     if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
23         install -d ${D}${sysconfdir}/modules-load.d
24         echo "aim_network" > ${D}${sysconfdir}/modules-load.d/aim_network.conf
25     fi
26 }
27
28 # These sources are currently for the porter kernel only
29 COMPATIBLE_MACHINE = "porter"