ea5acbbf7aafda375efc619ee3dad5cf98638c4f
[AGL/meta-agl-demo.git] / recipes-graphics / web-runtime / web-runtime_0.1.bb
1 inherit allarch
2
3 SUMMARY = "Provides the 'web-runtime' command"
4 DESCRIPTION = "The command 'web-runtime' is an abstraction that allows to "
5
6 LICENSE = "MIT"
7 LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
8
9 SRC_URI = "\
10     file://web-runtime;md5sum=2245be1e6029b30966f0842e3fee75ea \
11     file://web-runtime.qml;md5sum=922aeae6d596d7c83af01abca266f0df \
12     file://web-runtime-webkit.qml;md5sum=4daf9df39078634c27a7923d37e82e3d \
13 "
14
15 RDEPENDS_${PN} = "\
16   qtdeclarative-tools \
17   qtwayland-qmlplugins \
18   qtquickcontrols-qmlplugins \
19   qtwebengine \
20   runxdg \
21   bash \
22 "
23
24 PROVIDES += "virtual/webruntime"
25 # add also RPROVIDES to satisfy the packagegroup
26 RPROVIDES_${PN} += "virtual/webruntime"
27
28 do_configure() {
29     :
30 }
31
32 do_install() {
33     install -d ${D}${bindir}
34     install -m 0755 ${WORKDIR}/web-runtime ${D}${bindir}/web-runtime
35     install -m 0644 ${WORKDIR}/web-runtime.qml ${D}${bindir}/web-runtime.qml
36     install -m 0644 ${WORKDIR}/web-runtime-webkit.qml ${D}${bindir}/web-runtime-webkit.qml
37 }