3rd part of the layer/profile rework [2/2]
[AGL/meta-agl-demo.git] / recipes-graphics / web-runtime / web-runtime_0.1.bb
1 inherit allarch
2
3 SUMMARY = "Provides the 'web-runtime' command"
4 DESCRIPTION = "The command 'web-runtime' is an abstraction that allows to "
5
6 LICENSE = "MIT"
7 LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
8
9 SRC_URI = "\
10         file://web-runtime;md5sum=2245be1e6029b30966f0842e3fee75ea \
11         file://web-runtime.qml;md5sum=922aeae6d596d7c83af01abca266f0df \
12         file://web-runtime-webkit.qml;md5sum=4daf9df39078634c27a7923d37e82e3d \
13 "
14
15 RDEPENDS_${PN} = "\
16   qtdeclarative-tools \
17   qtwayland-qmlplugins \
18   qtquickcontrols-qmlplugins \
19 "
20
21 PROVIDES += "virtual/webruntime"
22 # add also RPROVIDES to satisfy the packagegroup
23 RPROVIDES_${PN} += "virtual/webruntime"
24
25 do_configure() {
26     :
27 }
28
29 do_install() {
30     install -d ${D}${bindir}
31     install -m 0755 ${WORKDIR}/web-runtime ${D}${bindir}/web-runtime
32     install -m 0644 ${WORKDIR}/web-runtime.qml ${D}${bindir}/web-runtime.qml
33     install -m 0644 ${WORKDIR}/web-runtime-webkit.qml ${D}${bindir}/web-runtime-webkit.qml
34 }
35
36 do_install_append_rcar-gen2() {
37         # workaround for porter board: force the use of libEGL provided by mesa at runtime
38         # otherwise, the proprietary libEGL is used and a problem then occurs due to a missing EGL function
39     sed -i 's|^\(exec /usr/bin/qt5/qmlscene\)|LD_PRELOAD=/usr/lib/libEGL.so \1|g' ${D}${bindir}/web-runtime
40 }
41
42