Remove systemd user session and clean up packagegroups and images
[AGL/meta-agl-demo.git] / recipes-graphics / wayland / weston-terminal-conf.bb
1 SUMMARY = "AGL user session"
2 LICENSE = "Apache-2.0"
3 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
4
5 inherit allarch agl-app
6
7 AGL_APP_ID = "org.freedesktop.weston.wayland-terminal"
8 AGL_APP_EXEC = "weston-terminal"
9 AGL_APP_NAME = "Weston Terminal"
10
11 do_install() {
12     # Enable systemd sandboxing override as a demonstration
13     install -d ${D}${systemd_system_unitdir}/agl-app@${AGL_APP_ID}.service.d/
14     ln -sf ${systemd_system_unitdir}/sandboxing/no-network.conf ${D}${systemd_system_unitdir}/agl-app@${AGL_APP_ID}.service.d/
15 }
16
17 FILES:${PN} = " \
18     ${sysconfdir}/systemd/system/agl-app@${AGL_APP_ID}.service.d \
19 "
20
21 RDEPENDS:${PN} = "weston-terminal"